Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)

Aiutami a crescere, condividi questo articolo...
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

Vediamo come simulare un CERCA.VERT con più condizioni usando le funzioni INDICE e CONFRONTA di Excel

cerca.vert usando più condizioniQuante volte avete la necessità di cercare un dato con CERCA.VERT con più condizioni? Scommetto che vi accade spesso, lo dico perché è una delle cose che mi vengono chieste più spesso.

Vi mostrerò in questo articolo come ottenere questo risultato usando INDICE e CONFRONTA perché, come sappiamo, CERCA.VERT non permette di definire più parametri per le ricerche.

Leggi tutto “Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)”

CERCA.VERT con colonna dinamica in Excel

Qualche tempo fa abbiamo visto una versione avanzata di CERCA.VERT realizzata usando INDICE e CONFRONTA che ci permetteva di recuperare un valore da una matrice indipendentemente dalla posizione della colonna, cosa che, normalmente, non è possibile fare, visto che CERCA.VERT permette di restituire solo le colonne a destra della colonna nella quale viene effettuata la ricerca.

Oggi vediamo come, sfruttando il normale CERCA.VERT, si possa ricavare il valore cercato da più colonne. Un esempio? Poniamo di avere una lista di clienti, ognuno di essi ha agganciato un listino diverso, come potremmo ottenere il prezzo a loro riservato per un dato prodotto usando CERCA.VERT? Semplice, invece di usare un numero fisso per la colonna da restituire usiamo la funzione CONFRONTA.

Leggi tutto “CERCA.VERT con colonna dinamica in Excel”

Valutare se un dato è presente o meno in una lista di Excel

Capita, a volte, di avere la necessità di sapere se un dato è presente in una lista o meno. Con i pochi articoli visti sino ad ora, ed un po’ di  fantasia e logica, dovreste essere in grado di scrivere una formula che possa risolvere questo semplice problema ma voglio rendervi la vita semplice svelandovi questo piccolo trucco.

Quello che ci serve sono tre funzioni, CERCA.VERT, VAL.NON.DISP e SE. Come ricorderete la prima cerca un valore in un insieme di dati e, se non lo trova, restituisce l’errore #N/D, la seconda serve appunto a gestire gli errori #N/D ed infine il SE ci serve per valutare il risultato di VAL.NON.DISP e mostrare il risultato.

Partiamo quindi con l’esempio pratico, immaginiamo di ricevere da un ipotetico distributore la lista dei prodotti che hanno in magazzino e che ci serva confrontarla con l’elenco dei prodotti che ci servono e di cui abbiamo i codici. Avremo a questo punto 2 liste (per semplicità ho messo tutto in un unico foglio):

Vediamo dunque come è possibile far si che Excel mostri Disponibile o Non disponibile a seconda dei casi. Ovviamente la prima funzione che mostrerà le due diverse stringhe è SE che valuterà una condizione che deve restituire VERO o FALSO, ripassiamola

=SE(condizione;se vero;se falso)

Nel nostro caso la condizione da valutare è il risultato di VAL.NON.DISP che restituisce VERO se una funzione genera un errore #N/D altrimenti ritorna il valore FALSO. La condizione che dovrà valutare è il nostro CERCA.VERT. Quindi la formula intera sarà:

=SE(VAL.NON.DISP(CERCA.VERT(E3;$A:$A;1;0));”NON DISPONIBILE”;”DISPONIBILE”)

Come si legge questa funzione? Se non è disponibile il valore di E3 nella ricerca verticale sulla colonna A di cui voglio come risultato il testo della prima colonna allora scrivi NON DISPONIBILE, altrimenti scrivi DISPONIBILE.

Sembra complicata come formula? Basta prenderci la mano e vi renderete conto che in fondo è semplicissima e può far risparmiare un sacco di tempo.

Per chiarimenti sono sempre qui.

A presto e continuate a seguire il Blog 🙂

Una versione più potente di CERCA.VERT

Nel post precedente sulla funzione di Excel CONFRONTA vi avevo promesso che vi avrei fatto vedere come essa può tornare utile in molti casi se usata insieme ad altre funzioni.

Come ricorderete anche nel post sulla funzione INDICE vi avevo detto che essa, da sola, è di scarsa utilità, allora sommiamo insieme queste due funzioni e scopriremo come realizzare una versione più potente di CERCA.VERT.

Leggi tutto “Una versione più potente di CERCA.VERT”

Cercare un valore in un insieme di dati Excel con la funzione CERCA.VERT

CERCA.VERT (o Cerca Verticale) è una delle funzioni più conosciute ed utilizzate di Microsoft Excel e fa parte di quelle funzioni che permettono di risparmiare un sacco di tempo ed incrementare la propria produttività.

Questa funzione permette di cercare un valore in un insieme di dati usando un altro valore come chiave di ricerca. Gli utilizzi sono i più disparati, per cercare un prodotto da un codice o il suo prezzo o, ancora, il nome di un’azienda o il suo indirizzo partendo dal codice.

Leggi tutto “Cercare un valore in un insieme di dati Excel con la funzione CERCA.VERT”

Come gestire gli errori #N/D

ND

Tempo fa (tanto tempo fa). in questo post vi illustravo quali sono gli errori che possono essere restituiti da Excel. Questi errori sono davvero fastidiosi soprattutto perché impediscono ad altre formule, correlate alla cella contenente l’errore, di funzionare correttamente, anche una semplice somma.

Vediamo allora come è possibile gestire gli errori #N/D.

Leggi tutto “Come gestire gli errori #N/D”