Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)

Aiutami a crescere, condividi questo articolo...
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

Vediamo come simulare un CERCA.VERT con più condizioni usando le funzioni INDICE e CONFRONTA di Excel

cerca.vert usando più condizioniQuante volte avete la necessità di cercare un dato con CERCA.VERT con più condizioni? Scommetto che vi accade spesso, lo dico perché è una delle cose che mi vengono chieste più spesso.

Vi mostrerò in questo articolo come ottenere questo risultato usando INDICE e CONFRONTA perché, come sappiamo, CERCA.VERT non permette di definire più parametri per le ricerche.

Leggi tutto “Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)”

CERCA.VERT con colonna dinamica in Excel

Qualche tempo fa abbiamo visto una versione avanzata di CERCA.VERT realizzata usando INDICE e CONFRONTA che ci permetteva di recuperare un valore da una matrice indipendentemente dalla posizione della colonna, cosa che, normalmente, non è possibile fare, visto che CERCA.VERT permette di restituire solo le colonne a destra della colonna nella quale viene effettuata la ricerca.

Oggi vediamo come, sfruttando il normale CERCA.VERT, si possa ricavare il valore cercato da più colonne. Un esempio? Poniamo di avere una lista di clienti, ognuno di essi ha agganciato un listino diverso, come potremmo ottenere il prezzo a loro riservato per un dato prodotto usando CERCA.VERT? Semplice, invece di usare un numero fisso per la colonna da restituire usiamo la funzione CONFRONTA.

Leggi tutto “CERCA.VERT con colonna dinamica in Excel”

Come trovare il valore in una cella alla data intersezione riga – colonna

Ciao a tutt, eccoci ad una nuova guida, con tanto di video, sull’uso combinato di due funzioni, INDICE e CONFRONTA. Vediamo di nuovo come queste due funzioni messe insieme possano essere utili.

Vi è mai capitato di dover riportare in una cella il valore di un’altra cella di cui non conoscevate, a priori, la posizione? O magari che la posizione di tale cella cambiasse continuamente?

Leggi tutto “Come trovare il valore in una cella alla data intersezione riga – colonna”

Valutare se un dato è presente o meno in una lista di Excel

Capita, a volte, di avere la necessità di sapere se un dato è presente in una lista o meno. Con i pochi articoli visti sino ad ora, ed un po’ di  fantasia e logica, dovreste essere in grado di scrivere una formula che possa risolvere questo semplice problema ma voglio rendervi la vita semplice svelandovi questo piccolo trucco.

Quello che ci serve sono tre funzioni, CERCA.VERT, VAL.NON.DISP e SE. Come ricorderete la prima cerca un valore in un insieme di dati e, se non lo trova, restituisce l’errore #N/D, la seconda serve appunto a gestire gli errori #N/D ed infine il SE ci serve per valutare il risultato di VAL.NON.DISP e mostrare il risultato.

Partiamo quindi con l’esempio pratico, immaginiamo di ricevere da un ipotetico distributore la lista dei prodotti che hanno in magazzino e che ci serva confrontarla con l’elenco dei prodotti che ci servono e di cui abbiamo i codici. Avremo a questo punto 2 liste (per semplicità ho messo tutto in un unico foglio):

Vediamo dunque come è possibile far si che Excel mostri Disponibile o Non disponibile a seconda dei casi. Ovviamente la prima funzione che mostrerà le due diverse stringhe è SE che valuterà una condizione che deve restituire VERO o FALSO, ripassiamola

=SE(condizione;se vero;se falso)

Nel nostro caso la condizione da valutare è il risultato di VAL.NON.DISP che restituisce VERO se una funzione genera un errore #N/D altrimenti ritorna il valore FALSO. La condizione che dovrà valutare è il nostro CERCA.VERT. Quindi la formula intera sarà:

=SE(VAL.NON.DISP(CERCA.VERT(E3;$A:$A;1;0));”NON DISPONIBILE”;”DISPONIBILE”)

Come si legge questa funzione? Se non è disponibile il valore di E3 nella ricerca verticale sulla colonna A di cui voglio come risultato il testo della prima colonna allora scrivi NON DISPONIBILE, altrimenti scrivi DISPONIBILE.

Sembra complicata come formula? Basta prenderci la mano e vi renderete conto che in fondo è semplicissima e può far risparmiare un sacco di tempo.

Per chiarimenti sono sempre qui.

A presto e continuate a seguire il Blog 🙂

Una versione più potente di CERCA.VERT

Nel post precedente sulla funzione di Excel CONFRONTA vi avevo promesso che vi avrei fatto vedere come essa può tornare utile in molti casi se usata insieme ad altre funzioni.

Come ricorderete anche nel post sulla funzione INDICE vi avevo detto che essa, da sola, è di scarsa utilità, allora sommiamo insieme queste due funzioni e scopriremo come realizzare una versione più potente di CERCA.VERT.

Leggi tutto “Una versione più potente di CERCA.VERT”

La funzione CONFRONTA di Excel

Aiutami a crescere, condividi questo articolo...
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

In questo articolo vi spiego come utilizzare la funzione confronta di Excel con tutte le sue opzioni ed esempi d’utilizzo

Ciao a tutti, eccoci qui con un’altra funzione sconosciuta ai più, CONFRONTA. Questa funzione ci permette di confrontare un dato valore con altri presenti in una lista e ne restituisce la posizione nella lista. Vediamo quali sono i parametri richiesti da questa funzione

=CONFRONTA(Valore;Matrice;[Corrispondenza])

  • Valore: rappresenta il valore che vogliamo cercare, può essere una cella, una data, un numero, un testo, ecc.
  • Matrice: l’elenco dei valori all’interno dei quali vogliamo effettuare la ricerca
  • [Corrispondenza]: un parametro opzionale che indica che tipo di corrispondenza deve esserci nel confronto e può assumere uno di questi valori:
    • 1: vuol dire “Minore di”, cerca un valore uguale a quello che abbiamo indicato e, se non viene trovato, viene restituito il valore immediatamente inferiore, se non esiste un valore inferiore verrà restituito l’errore di tipo #N/D
    • 0: vuol dire “Corrispondenza esatta”, se il valore non viene trovato restituisce un errore di tipo #N/D
    • -1: vuol dire “Maggiore di”, cerca un valore uguale a quello che abbiamo indicato e, se non viene trovato, viene restituito il valore immediatamente maggiore, se non esiste un valore maggiore verrà restituito l’errore di tipo #N/D

    Se non viene indicato nessuno di questi valori Excel selezionerà automaticamente il tipo di corrispondenza 0.

Leggi tutto “La funzione CONFRONTA di Excel”

La funzione INDICE di Excel

Ecco una funzione che raramente ho visto nei file di Excel, INDICE. Certo, il nome che le hanno dato è orribile perché, a mio avviso, non rispecchia ciò che realmente fa questa funzione. Il suo scopo è quello di restituire il valore di una cella all’interno di un range indicando la sua posizione attraverso le coordinate numero riga e numero colonna.

Esistono due forme di questa funzione, matrice (ma non abbiamo ancora visto come funzionano le matrici quindi la delego ad un prossimo post) ed una riferimento.

Cercherò di essere più chiaro ma iniziamo con il vedere i parametri della funzione in forma riferimento


=INDICE(intervallo dati; numero riga; numero colonna)

  • Intervallo dati è l’elenco dei dati presi in esame (il range) come, ad esempio A1:B6
  • Numero riga è il numero della riga che contiene il valore si vuole recuperare all’interno dell’elenco
  • Numero colonna è il numero della colonna che contiene il valore che si vuole recuperare all’interno dell’elenco

E’ più facile a farsi che a dirsi

=INDICE(A1:B6;3;2)

Restituisce il valore di B3.

Ecco un video che mostra l’uso della funzione INDICE

Benché questa funzione, di per se, sembra poco utile, usata in combinazione con altre diventa veramente potente ma vedremo come in un prossimo articolo, per ora tenetela a mente 🙂

A presto

Cercare un valore in un insieme di dati Excel con la funzione CERCA.VERT

CERCA.VERT (o Cerca Verticale) è una delle funzioni più conosciute ed utilizzate di Microsoft Excel e fa parte di quelle funzioni che permettono di risparmiare un sacco di tempo ed incrementare la propria produttività.

Questa funzione permette di cercare un valore in un insieme di dati usando un altro valore come chiave di ricerca. Gli utilizzi sono i più disparati, per cercare un prodotto da un codice o il suo prezzo o, ancora, il nome di un’azienda o il suo indirizzo partendo dal codice.

Leggi tutto “Cercare un valore in un insieme di dati Excel con la funzione CERCA.VERT”

Estrarre una parte di una stringa con STRINGA.ESTRAI

Eccoci qui per un altro piccolo tutorial su Excel. Ieri ho postato una formula utile per validare un indirizzo email e qualche amico mi ha chiesto delucidazioni su un paio di funzioni, una delle quali è STRINGA.ESTRAI, vediamo quindi come estrarre una parte di una stringa con STRINGA.ESTRAI.

La sintassi è molto semplice:

STRINGA.ESTRAI(testo;inizio;numero_di_caratteri)

Leggi tutto “Estrarre una parte di una stringa con STRINGA.ESTRAI”