Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)

Aiutami a crescere, condividi questo articolo...
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

Vediamo come simulare un CERCA.VERT con più condizioni usando le funzioni INDICE e CONFRONTA di Excel

cerca.vert usando più condizioniQuante volte avete la necessità di cercare un dato con CERCA.VERT con più condizioni? Scommetto che vi accade spesso, lo dico perché è una delle cose che mi vengono chieste più spesso.

Vi mostrerò in questo articolo come ottenere questo risultato usando INDICE e CONFRONTA perché, come sappiamo, CERCA.VERT non permette di definire più parametri per le ricerche.

Leggi tutto “Un CERCA.VERT con più condizioni (usando INDICE e CONFRONTA)”

Come trovare il valore in una cella alla data intersezione riga – colonna

Ciao a tutt, eccoci ad una nuova guida, con tanto di video, sull’uso combinato di due funzioni, INDICE e CONFRONTA. Vediamo di nuovo come queste due funzioni messe insieme possano essere utili.

Vi è mai capitato di dover riportare in una cella il valore di un’altra cella di cui non conoscevate, a priori, la posizione? O magari che la posizione di tale cella cambiasse continuamente?

Leggi tutto “Come trovare il valore in una cella alla data intersezione riga – colonna”

Una versione più potente di CERCA.VERT

Nel post precedente sulla funzione di Excel CONFRONTA vi avevo promesso che vi avrei fatto vedere come essa può tornare utile in molti casi se usata insieme ad altre funzioni.

Come ricorderete anche nel post sulla funzione INDICE vi avevo detto che essa, da sola, è di scarsa utilità, allora sommiamo insieme queste due funzioni e scopriremo come realizzare una versione più potente di CERCA.VERT.

Leggi tutto “Una versione più potente di CERCA.VERT”

La funzione INDICE di Excel

Ecco una funzione che raramente ho visto nei file di Excel, INDICE. Certo, il nome che le hanno dato è orribile perché, a mio avviso, non rispecchia ciò che realmente fa questa funzione. Il suo scopo è quello di restituire il valore di una cella all’interno di un range indicando la sua posizione attraverso le coordinate numero riga e numero colonna.

Esistono due forme di questa funzione, matrice (ma non abbiamo ancora visto come funzionano le matrici quindi la delego ad un prossimo post) ed una riferimento.

Cercherò di essere più chiaro ma iniziamo con il vedere i parametri della funzione in forma riferimento


=INDICE(intervallo dati; numero riga; numero colonna)

  • Intervallo dati è l’elenco dei dati presi in esame (il range) come, ad esempio A1:B6
  • Numero riga è il numero della riga che contiene il valore si vuole recuperare all’interno dell’elenco
  • Numero colonna è il numero della colonna che contiene il valore che si vuole recuperare all’interno dell’elenco

E’ più facile a farsi che a dirsi

=INDICE(A1:B6;3;2)

Restituisce il valore di B3.

Ecco un video che mostra l’uso della funzione INDICE

Benché questa funzione, di per se, sembra poco utile, usata in combinazione con altre diventa veramente potente ma vedremo come in un prossimo articolo, per ora tenetela a mente 🙂

A presto