La funzione PIÙ.SE di Excel 2016

Aiutami a crescere, condividi questo articolo...
  • 4
  •  
  •  
  • 12
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
    16
    Shares

In questo articolo scopriamo la funzione PIÙ.SE introdotta con Microsoft Excel 2016 che vi permette di evitare i SE nidificati e vi semplificherà la vita.

Dopo tanto tempo torno finalmente a scrivere un articolo, quella che voglio presentarvi oggi è la funzione PIÙ.SE introdotta con Microsoft Excel 2016, se avete un abbonamento ad Office 365 dovreste averla già disponibile.

La funzione PIÙ.SE permette di valutare diverse condizioni ed ottenere il risultato che corrisponde alla prima condizione che restituisce VERO.

funzione_più_se_excel_2016
La funzione PIÙ.SE introdotta con Excel 2016

Leggi tutto “La funzione PIÙ.SE di Excel 2016”

Formule matriciali in Excel (Prima Parte)

Dopo un po’ di esperienza con le funzioni e le formule di Excel è ora di iniziare a parlare di qualcosa di più avanzato, nella fattispecie delle formule matriciali o formule in forma di matrice. Non avete capito cosa possa significare? Bene, sono qui per spiegarlo.

Le formule matriciali in Excel sono formule particolari costruite con le normali funzioni di Excel ma che permettono di eseguire calcoli che, nella forma classica delle formule, non sarebbe possibile eseguire.

Leggi tutto “Formule matriciali in Excel (Prima Parte)”

Valutare se un dato è presente o meno in una lista di Excel

Capita, a volte, di avere la necessità di sapere se un dato è presente in una lista o meno. Con i pochi articoli visti sino ad ora, ed un po’ di  fantasia e logica, dovreste essere in grado di scrivere una formula che possa risolvere questo semplice problema ma voglio rendervi la vita semplice svelandovi questo piccolo trucco.

Quello che ci serve sono tre funzioni, CERCA.VERT, VAL.NON.DISP e SE. Come ricorderete la prima cerca un valore in un insieme di dati e, se non lo trova, restituisce l’errore #N/D, la seconda serve appunto a gestire gli errori #N/D ed infine il SE ci serve per valutare il risultato di VAL.NON.DISP e mostrare il risultato.

Partiamo quindi con l’esempio pratico, immaginiamo di ricevere da un ipotetico distributore la lista dei prodotti che hanno in magazzino e che ci serva confrontarla con l’elenco dei prodotti che ci servono e di cui abbiamo i codici. Avremo a questo punto 2 liste (per semplicità ho messo tutto in un unico foglio):

Vediamo dunque come è possibile far si che Excel mostri Disponibile o Non disponibile a seconda dei casi. Ovviamente la prima funzione che mostrerà le due diverse stringhe è SE che valuterà una condizione che deve restituire VERO o FALSO, ripassiamola

=SE(condizione;se vero;se falso)

Nel nostro caso la condizione da valutare è il risultato di VAL.NON.DISP che restituisce VERO se una funzione genera un errore #N/D altrimenti ritorna il valore FALSO. La condizione che dovrà valutare è il nostro CERCA.VERT. Quindi la formula intera sarà:

=SE(VAL.NON.DISP(CERCA.VERT(E3;$A:$A;1;0));”NON DISPONIBILE”;”DISPONIBILE”)

Come si legge questa funzione? Se non è disponibile il valore di E3 nella ricerca verticale sulla colonna A di cui voglio come risultato il testo della prima colonna allora scrivi NON DISPONIBILE, altrimenti scrivi DISPONIBILE.

Sembra complicata come formula? Basta prenderci la mano e vi renderete conto che in fondo è semplicissima e può far risparmiare un sacco di tempo.

Per chiarimenti sono sempre qui.

A presto e continuate a seguire il Blog 🙂

Come gestire gli errori #N/D

ND

Tempo fa (tanto tempo fa). in questo post vi illustravo quali sono gli errori che possono essere restituiti da Excel. Questi errori sono davvero fastidiosi soprattutto perché impediscono ad altre formule, correlate alla cella contenente l’errore, di funzionare correttamente, anche una semplice somma.

Vediamo allora come è possibile gestire gli errori #N/D.

Leggi tutto “Come gestire gli errori #N/D”

La funzione SE di Excel

Dopo aver visto il tipo di dati Vero e Falso ci possiamo dedicare alla prima funzione che fa uso di questo tipo di dati, la funzione SE di Excel.

SE è una funzione usata per valutare una condizione e, in base al risultato, ritornare un valore o eseguire un’altra funzione.

Vediamo come funziona nel dettaglio, prima di tutto il numero di parametri da passare sono 3, la condizione da valutare, il valore da ritornare in caso il risultato dell’espressione sia Vero e quello da ritornare per Falso.

=SE(espressione;valore se vero; valore se falso)

Leggi tutto “La funzione SE di Excel”

Vero o Falso?

vero o falso

In Excel tutti sono abituati a lavorare con diversi tipi di dati, solitamente questi dati sono di tipo numerico, testuale e date. Ma c’è anche un altro tipo di dati, Vero e Falso. Questo tipo di dati, detto anche booleano, è utile soprattutto nella realizzazione di formule più o meno complesse come il SE e in molte Macro.

Leggi tutto “Vero o Falso?”