EUCOOKIELAW_BANNER_TITLE

Come gestire gli errori #N/D

ND

Tempo fa (tanto tempo fa). in questo post vi illustravo quali sono gli errori che possono essere restituiti da Excel. Questi errori sono davvero fastidiosi soprattutto perché impediscono ad altre formule, correlate alla cella contenente l’errore, di funzionare correttamente, anche una semplice somma.

Vediamo allora come è possibile gestire gli errori #N/D.

Come ricorderete questo errore si verifica quando un valore risultante da una formula non è disponibile. Un classico caso sono i risultati della formula CERCA.VERT().

Poniamo un esempio. Create un foglio di lavoro con i seguenti valori:

A1: Mele | B1: 10
A2: Pere | B2: 20
A3: Meloni | B3: 30

Il risultato dovrebbe essere questo

errori_nd_1

Ora posizionatevi su A5 e scrivete “Mele” e in B5 la seguente formula:

=CERCA.VERT(A5;A1:B3;2;0)

Vedremo più avanti, nel dettaglio, la funzione CERCA.VERT(), per ora limitiamoci a notare come il risultato della stessa sia 10, ovvero il valore di mele.
errori_nd_2

Praticamente la funzione cerca la parola “Mele” nella prima colonna e restituisce il valore della seconda colonna. Ora, provate a cambiare il valore della cella A5 in “Ciliege” e noterete che si verifica un errore

errori_nd_3

 

Ora, questo errore oltre che antiestetico e poco utile è anche fonte di problemi per altre formule che fanno uso della cella. Vediamo come risolverlo con una “piccola” modifica:

=SE(VAL.NON.DISP(CERCA.VERT(A5;A1:B3;2;0));0;CERCA.VERT(A5;A1:B3;2;0))

Abbiamo introdotto una nuova funzione chiamata VAL.NON.DISP() che significa Valore non disponibile.Questa funzione restituisce un valore VERO o FALSO. L’unico parametro da passare fra parentesi è la formula che vogliamo valutare.

Anche se sembra complessa come formula è estremamente semplice. Analizziamola nel suo complesso

=SE( 

iniziamo la nostra formula di valutazione chiedento ad Excel di valutare una condizione con il SE. La condizione da valutare è la nostra VAL.NON.DISP

VAL.NON.DISP(

a questo punto bisogna indicare quale formula valutare, in questo caso il nostro CERCA.VERT

CERCA.VERT(A5;A1:B3;2;0)

a questo punto chiudiamo le parentesi di VAL.NON.DISP e continuiamo con il valore da restituire nel caso la stessa ritorni VERO, in questo caso 0.

;0;

e poi la formula nel caso invece il risultato sia falso, quindi nuovamente il nostro CERCA.VERT()

 

Riassumento la formula dice (in italiano per semplificare)

Se il valore della ricerca che ho effettuato non è disponibile allora restituiscimi 0 altrimenti dammi il risultato.

errori_nd_4

Ovviamente al posto dello 0 potremmo metterci qualunque cosa. Mi viene in mente una fattura dove abbiamo i codici articolo e la loro descrizione, scrivendo un codice non valido potrebbe apparire la scritta “CODICE NON VALIDO” oppure effettuare ricerche in diversi elenchi sino a quando non si trova il valore desiderato.

Vedremo anche esempi più completi un po’ più avanti 🙂

Grazie di aver letto si qui e spero che vi sia stato utile. Se avete dubbi, o se mi sono espresso male, segnalatemelo nei commenti 🙂


MESSAGGIO DALL'AUTORE
Aiutami a far conoscere questo blog ad altre persone perché possa aiutare anche loro, condividi questo articolo su Facebook, Twitter, Google+ o Linkedin, non ti costa nulla e mi aiuterà a diffonderlo dandomi l'ispirazione per scrivere altri articoli.

gianfranco

Appassionato di informatica, fotografia e di tecnologia in generale. Esperto nell'uso di Excel e con tanta voglia di condividere le sue conoscenza con il mondo, sempre pronto a dare una mano (ma non più di due volte, altrimenti rimango senza).

Potrebbero interessarti anche...

3 Risposte

  1. roberta crudo ha detto:

    Bravo!!!!

  1. 10 Giugno 2015

    […] l’articolo che ho scritto qualche tempo fa su come gestire gli errori #N/D ho pensato che fosse il momento di spiegare anche come gestire gli altri errori, soprattutto […]

  2. 26 Gennaio 2017

    […] nessuna delle condizioni inserite la formula restituirà l’errore #N/D. Il limite di accoppiate condizione / risultato che si possono inserire è di […]

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: