EUCOOKIELAW_BANNER_TITLE

La funzione INDICE di Excel

Ecco una funzione che raramente ho visto nei file di Excel, INDICE. Certo, il nome che le hanno dato è orribile perché, a mio avviso, non rispecchia ciò che realmente fa questa funzione. Il suo scopo è quello di restituire il valore di una cella all’interno di un range indicando la sua posizione attraverso le coordinate numero riga e numero colonna.

Esistono due forme di questa funzione, matrice (ma non abbiamo ancora visto come funzionano le matrici quindi la delego ad un prossimo post) ed una riferimento.

Cercherò di essere più chiaro ma iniziamo con il vedere i parametri della funzione in forma riferimento


=INDICE(intervallo dati; numero riga; numero colonna)

  • Intervallo dati è l’elenco dei dati presi in esame (il range) come, ad esempio A1:B6
  • Numero riga è il numero della riga che contiene il valore si vuole recuperare all’interno dell’elenco
  • Numero colonna è il numero della colonna che contiene il valore che si vuole recuperare all’interno dell’elenco

E’ più facile a farsi che a dirsi

=INDICE(A1:B6;3;2)

Restituisce il valore di B3.

Ecco un video che mostra l’uso della funzione INDICE

Benché questa funzione, di per se, sembra poco utile, usata in combinazione con altre diventa veramente potente ma vedremo come in un prossimo articolo, per ora tenetela a mente 🙂

A presto


MESSAGGIO DALL'AUTORE
Sai che puoi iscriverti anche alla newsletter e ricevere le novità direttamente nella tua email? Iscriviti adesso, riceverai solo gli aggiornamenti e niente SPAM. Il tuo indirizzo, inoltre, non sarà condiviso con nessuno.

gianfranco

Appassionato di informatica, fotografia e di tecnologia in generale. Esperto nell'uso di Excel e con tanta voglia di condividere le sue conoscenza con il mondo, sempre pronto a dare una mano (ma non più di due volte, altrimenti rimango senza).

Potrebbero interessarti anche...

2 Risposte

  1. Stefano ha detto:

    Ciao

    Ma se io volessi l’indice di una cella calcolata?
    Ho due colonne:
    – A (Data) con le date da oggi fino alla fine dell’anno.
    – B (Temperatura) con i risultati corrispondenti al giorno (p.es La temperatura massima di ogni giorno)

    Mi faccio poi uno specchietto riassuntivo con gli ultimi dati inseriti

    Con la formula CERCA(2;1/(1-VAL.VUOTO(B:B));B:B) trovo l’ultima temperatura registrata. Ora vorrei visualizzare la data corrispondente a questa temperatura. Pensavo di usare la funzione SCARTO immettendo l’INDICE dell’ultima cella trovata.
    Qualcosa del genere (pseudocodice)

    SCARTO(INDICE di “CERCA(2;1/(1-VAL.VUOTO(B:B));B:B), 0, -1)

    Però non funziona.Come riesco a risolverla tenendo presente che voglio avere già tutte le date di quest’anno? (Altrimenti sarebbe banale)

    Grazie 🙂

    Grazie

  1. 22 Luglio 2016

    […] a questo punto pensare ad un approccio diverso, in Excel esiste una funzione chiamata INDICE (qui un approfondimento) che permette di selezionare una cella all’interno di un intervallo passando il numero di […]

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: