Cercare un valore in un insieme di dati Excel con la funzione CERCA.VERT

CERCA.VERT (o Cerca Verticale) è una delle funzioni più conosciute ed utilizzate di Microsoft Excel e fa parte di quelle funzioni che permettono di risparmiare un sacco di tempo ed incrementare la propria produttività.

Questa funzione permette di cercare un valore in un insieme di dati usando un altro valore come chiave di ricerca. Gli utilizzi sono i più disparati, per cercare un prodotto da un codice o il suo prezzo o, ancora, il nome di un’azienda o il suo indirizzo partendo dal codice.

La funzione CERCA.VERT ha la seguente struttura

=CERCA.VERT(Valore,Intervallo di dati,Indice,Intervallo)

  • Valore: è il valore che vogliamo cercare o il riferimento ad una cella che contiene il valore
  • Insieme di dati: è l’insieme di dati all’interno dei quali vogliamo effettuare la ricerca. La prima colonna di questo insieme è quella in cui verrà effettuata la ricerca.
  • Indice: è il numero di colonna che contiene il valore che vogliamo ottenere, tenendo conto che 1 rappresenta la colonna in cui viene effettuata la ricerca
  • Intervallo: è un valore logico che consente di specificare se CERCA.VERT deve trovare una corrispondenza esatta o approssimativa, si può specificare come FALSO o VERO (in alternativa, più velocemente, 0 o 1). Il consiglio che vi do è quello di impostare sempre a FALSO (o 0) questo valore per indicare una corrispondenza esatta, altrimenti correte il rischio di trovarvi di fronte a risultati inaspettati.

Un’annotazione particolare, l’indice non può essere mai negativo, questo vuol dire che se cercate un valore nella colonna C non potrete ottenere una valore nella colonna B.

Passiamo ad un esempio pratico

Poniamo di voler trovare il valore di Pere, posizioniamoci in una cella vuota e digitiamo la seguente formula:

=CERCA.VERT("Pere";$B$3:$C$7;2;0)

notate che è importante bloccare le celle, altrimenti trascinando la formula in altre celle il riferimento della matrice dei dati cambierà continuamente.

E’ inoltre importante notare che se sono presenti più occorrenze verrà restituito soltanto il primo valore della lista.

Se il valore non viene trovato verrà restituito un errore di tipo #N/D.

Tutto chiaro? Se non lo è chiedete pure attraverso i commenti

[random_sc]

A presto


MESSAGGIO DALL'AUTORE
Se pensi che questo articolo ti sia stato utile e vuoi supportare questo sito puoi offrirmi un caffé con una piccola donazione. Mi aiuterai a sostenere le spese di gestione del sito.


gianfranco

Appassionato di informatica, fotografia e di tecnologia in generale. Esperto nell'uso di Excel e con tanta voglia di condividere le sue conoscenza con il mondo, sempre pronto a dare una mano (ma non più di due volte, altrimenti rimango senza).

Potrebbero interessarti anche...

Una risposta

  1. Josie ha detto:

    Codesto intervento mi trova completamente d’accordo. In linea generale
    il sito web http://www.tuttoexcel.it è redattoveramente in modo efficace, mi piace.

    Ottimo lavoro, a presto!

    leggi questo sito

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: