EUCOOKIELAW_BANNER_TITLE

Somma condizionale con la funzione SOMMA.SE

Abbiamo appena parlato della funzione SOMMA, regina incontrastata dei fogli di Excel, la parente più prossima penso sia SOMMA.SE.

Anche quest’ultima, come la sua “cugina” ha lo scopo di sommare un’insieme di valori, quello che la rende speciale è quel .SE alla fine che fa intendere che ci sarà una condizione per la somma, vediamo come si presenta

=SOMMA.SE(intervallo_dati;criterio;[intervallo_somma])

  • Intervallo: è l’intervallo dati sul quale verrà applicato il criterio
  • Criterio: è il vostro filtro, verranno sommati solo i dati che corrispondono ad esso
  • Intervallo_somma: è l’intervallo dei dati da sommare, può essere omesso se è uguale all’intervallo dei dati su cui si applica il criterio

Partiamo quindi con il nostro solito esempio, prendiamo questo insieme di dati come esempio

Come vedete, per ottenere la somma dei numeri in corrispondenza della voce “Pere” la nostra formula sarà:

=SOMMA.SE(A:A;D2;B:B)

che si legge come “Se la cella Ax contiene la voce presente nella cella D2 allora sommami il valore contenuto nella cella Bx“, ripetuto per tutte le celle della colonna A, alla fine, come totale, avremo 14. Basta cambiare il vaore della cella D2 per vedere un nuovo totale.

Se invece vogliamo sommare solo i valori uguali a 5 nella colonna B possiamo scrivere questa formula

=SOMMA.SE(B:B;5)

ed il risultato è 10. Cosa fa la formula SOMMA.SE in questo caso? Prende tutti i valori di B e somma solo quelli uguali a 5. Come vedete, in questo caso, è possibile omettere l’Intevallo_somma all’interno della funzione.

Una piccola nota: a differenza di altre formule, come ad esempio CERCA.VERT, qui il maiuscolo/minuscolo è ignorato, quindi PERE e Pere sono la stessa cosa.

Sono stato abbastanza chiaro? Ditemelo, i commenti sono aperti a tutti 🙂


MESSAGGIO DALL'AUTORE
Sai che puoi iscriverti anche alla newsletter e ricevere le novità direttamente nella tua email? Iscriviti adesso, riceverai solo gli aggiornamenti e niente SPAM. Il tuo indirizzo, inoltre, non sarà condiviso con nessuno.

gianfranco

Appassionato di informatica, fotografia e di tecnologia in generale. Esperto nell'uso di Excel e con tanta voglia di condividere le sue conoscenza con il mondo, sempre pronto a dare una mano (ma non più di due volte, altrimenti rimango senza).

Potrebbero interessarti anche...

4 Risposte

  1. PAOLA ha detto:

    Ciao Gianfranco, rieccomi, non so se è la sezione giusta ma ho un altro quesito. Ho provato ad utilizzare SOMMA.SE e CERCA.VERT adattando la tua formula alla mia tabella, ma niente! Intanto volevo sapere se ho capito bene : SOMMA. SE si utilizza solo per valori numerici e CERCA.VERT solo per valori non numerici ?
    Divisa Tuta Borsa Calze Tshirt
    Iulia Alexandra S S X X X
    Clelia M S X X X
    Laura M M X ok ok
    Paula S S ok ok ok
    Chiara S S ok ok ok
    Elena S S ok ok ok
    Valentina M S X X X
    Alexandra S S ok ok ok
    Francesca M S X X X
    Federica L M X X X
    Elisabetta M M X ok ok
    Giulia M S X X X
    Federica S S X X X

    S quanti nella colonna? S ?
    M ? M ?
    L ? L ?

    HO la necessità di sapere la quantità di lettere S,M,L per ogni colonna , da indicare nelle celle sottostanti. Ti ringrazio per il tuo aiuto e la disponibilità. Paola

    • gianfranco ha detto:

      Ciao Paola,
      per il tuo caso non servono ne il somma.se né il cerca.vert ma il conta.se. La formula che ti serve è


      =CONTA.SE(A2:A10;"S")

      per contare le S,


      =CONTA.SE(A2:A10;"M")

      per contare le M e così via. Per rispondere all’altro quesito, SOMMA.SE effettua la somma dei valori che corrispondono ad una data condizione, la condizione può essere applicata alla stessa colonna che contiene i numeri o ad un’altra colonna.

      Ad esempio, se hai le colonne


      A B
      1 Pere 1
      2 Mele 1
      3 Pere 2
      4 Banane 5

      e vuoi sommare i valore di Pere devi scrivere la formula


      =SOMMA.SE(A1:A4;"Pere";B1:B4)

      restituisce 3 ovvero la somma delle celle della colonna B dove nella medesima riga della colonna A è presente la parola Pere. L’altra opzione, invece è


      =SOMMA.SE(B1:B4;">1")

      ti somma i valori della colonna B che sono maggiori di 1, quindi il risultato è 7.

      Discorso diverso invece per CERCA.VERT, serve a trovare il primo valore in una tabella che corrisponde ad un dato criterio, il valore restituito può essere numerico, testuale, una data o qualunque altro formato. Ti consiglio di leggere l’articolo dedicato però 🙂

      Se hai ancora bisogno o non ti è chiaro qualcosa scrivi pure, se vuoi che ti aiuti direttamente sul file mandami una mail privata, trovi l’indirizzo nella sezione CONTATTAMI nel menu in alto

      A presto

  2. Francesco ha detto:

    come posso superare il limite delle 255 stringhe se ho un elenco di ricerca di più di 500 voci, ho provato a sommare due somma.se, ho provato a dividere due somma.se uno che ricerca i valori da 1 a 250 e 250 a 500.
    potete darmi un consiglio?

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: