EUCOOKIELAW_BANNER_TITLE

La funzione SE di Excel

Dopo aver visto il tipo di dati Vero e Falso ci possiamo dedicare alla prima funzione che fa uso di questo tipo di dati, la funzione SE di Excel.

SE è una funzione usata per valutare una condizione e, in base al risultato, ritornare un valore o eseguire un’altra funzione.

Vediamo come funziona nel dettaglio, prima di tutto il numero di parametri da passare sono 3, la condizione da valutare, il valore da ritornare in caso il risultato dell’espressione sia Vero e quello da ritornare per Falso.

=SE(espressione;valore se vero; valore se falso)

Proviamo a creare una formula funzionante che possa essere usata nel mondo reale, un qualcosa di pratico insomma. Creiamo un sistema che applichi uno sconto ad un prodotto se la quantità supera un certo limite. Poniamo di avere il seguente schema:

Lo schema di base è molto semplice ma contiene tutto quello che ci serve per il nostro piccolo esempio. La formula illustrata (se volete copiarla) è:

=SE(B2>10;(C2-(C2*0,1))*B2;C2*B2)

Analizziamone i singoli parametri

  • B2>10: è l’espressione da valutare, se B2 è maggiore di 10 allora applicheremo lo sconto del 10%
  • (C2-(C2*0,1))*B2: se la condizione è vera calcolo il nuovo prezzo scontato (C2-(C2*0,1)) e lo moltiplico per la quantità in B2. Lo sconto del 10% è rappresentato da 0,1.
  • C2*B2: se l’espressione da Falso come risultato semplicemente moltiplico prezzo per quantità

Ed ecco il risultato:

 

In questo caso l’espressione da valutare è stata volutamente semplice ma, ovviamente, se ne possono fare di più complesse. Vedremo nei prossimi articoli come usare SE per risolvere tanti problemi di ogni tipo.

Ovviamente per ogni chiarimento e/o approfondimento sono aperti i commenti


MESSAGGIO DALL'AUTORE
Hai trovato questo blog utile o interessante? Lascia una tua opinione sul guestbook per farmi sapere cosa ne pensi e come possa migliorarlo.

gianfranco

Appassionato di informatica, fotografia e di tecnologia in generale. Esperto nell'uso di Excel e con tanta voglia di condividere le sue conoscenza con il mondo, sempre pronto a dare una mano (ma non più di due volte, altrimenti rimango senza).

Potrebbero interessarti anche...

6 Risposte

  1. MGSRL ha detto:

    HO BISOGNO DI UNA FORMULA CHE MI RESTITUISCA UN VALORE ( 225) SE IL PRODOTTO DI DUE OPERAZIONI è INFERIORE A 225

    CAMPO A LARGHEZZA 70
    CAMPO B ALTEZZA 120
    CAMPO C MQ 0,84
    CAMPO D COSTO AL MQ 150
    CAMPO E COSTO INFISSO ?
    CAMPO F MINIMO FATTURATO 1,5 mQ

  2. Olsen ha detto:

    Ciao,
    l'operazione è molto semplice, poniamo che i valori da sommare (o moltiplicare, non cambia) siano nelle celle A1 e A2. Nella cella A3 scriveremo:

    =SE(A1+A2<225;225;A1+A2)

    praticamente la formula dice: se A1 + A2 è inferiore a a 225 allora metti 225 altrimenti metti A1 + A2

    dai dati messi così non capisco quali siano le operazioni da effettuare, se non riesci spiegami quali sono i calcoli da fare e ti scrivo la formula 🙂

  3. MGSRL ha detto:

    grazie di tutto

  4. Gianluca Tinti ha detto:

    Salve vivissimi complimenti per il Blog, è molto interessante. Anch'io ne gestisco uno simile:
    http://www.automaticando.com/

  5. pierpaolo ha detto:

    Ciao, potresti aiutarmi?
    Ho una situazione particolare, ho 3 celle in sequenza in cui in una sola è presente una “x”. Vorrei creare una funzione che riconosca in quale cella c’è la “x” e mi restituica un valore di mia scelta.
    Esempio: se la x è nella prima cella allora scrivi “ciao”, se è nella seconda scivi “addio” ecc ecc.

    • gianfranco ha detto:

      Ciao Paolo,
      certo che posso aiutarti. Seguendo il tuo esempio, e dando per assunto che è presente solo e solo una X in una delle 3 celle, puoi usare uno di questi 2 metodi. Il primo di basa su una serie di SE nidificati tra di loro:

      =SE(A1="x";"ciao";SE(B1="x";"addio";SE(C1="x";"bentornato";"")))

      Il secondo invece usa l’equivalenza fra 1=VERO e 0=FALSO, un po’ di matematica e la funzione SCEGLI

      =SE.ERRORE(SCEGLI(((A1="x")*1)+((B1="x")*2)+((C1="x")*3);"ciao";"addio";"bentornato");"")

      In entrambi i casi se non ci sono X viene restituito un valore vuoto

      a presto

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: